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Installation Guide

Introduction

NOTE: PowerLogic Tenant Metering Software—Commercial Edition version
2.5 must be installed on your system before installing PowerLogic File
Transfer Utility.

PowerLogic File Transfer Utility is an add-on module for PowerLogic Tenant
Metering Software—Commercial Edition (TMSCE) version 2.5. With File
Transfer Utility (FTU), users of TMSCE can easily incorporate metered data
from E4800 multi-circuit devices and EGX300 gateway devices into their
billing system.

The File Transfer Utility service processes File Transfer Protocol (FTP) files
that are pushed by the EGX300 and E4800 devices into a drop folder on an
FTP server. Once the files in the drop folder are processed, they are moved
to an archive folder. Metered data is moved into the Meter Reading
database where it is incorporated with all other TMSCE data before
continuing through the billing system.

PowerLogic File Transfer Utility supports the following PowerLogic devices:

® E4800 multi-circuit meter
* Meters supported by TMSCE via EGX300

— CM2000, CM3000, CM4000

— Compact

— Enercept

— Energy Meter

— ION6200 family

— ION7300 family

— ION7500 family

— ION7600 family

— Micrologic P, H, P+CCM, H+CCM

— PM200 family

— PM300 family

— PM500 family

— PM600 PowerLogic, Modbus

— PM700 family

— PMB800 family

— PM900c

— Sepam 2000

— Sepam Series 40, 80
NOTE: If you are using ION meters with an EGX300 device that was
manufactured before 18 May 2009, you need to update your EGX300.

Download the update at www.powerlogic.com or call customer support at
615.287.3400.
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Prerequisites

Document Description

Minimum System Requirements

Windows Vista Users

Before you can successfully use File Transfer Utility with TMSCE, the
following components must be installed and running:

® TMSCE 2.5 or later

e FTP server

See “Setting up the FTP Server” for more information on the FTP server.

See the PowerLogic Tenant Metering Software—Commercial Edition
Installation Guide for more information on installing TMSCE.

NOTE: If you want to receive e-mail notification when FTU detects missing
interval data from devices, you must also have an e-mail server (SMTP)
available.

This document describes the installation process for PowerLogic File
Transfer Utility. It also contains information on configuring the FTP server.

PowerLogic File Transfer Utility can be installed in any of the following
operating systems:

* Microsoft® Windows® Vista Ultimate SP1 or higher

* Microsoft Windows Vista Business SP1 or higher

* Microsoft Windows XP Professional SP3 or higher

* Microsoft Server 2003 Standard SP2 or higher

File Transfer Utility will install on a system that fully supports TMSCE 2.5.

The User Account Control (UAC) feature is a security enhancement that is
automatically engaged in Windows Vista to prevent unauthorized programs
from installing on your computer. File Transfer Utility is designed to be
compatible with the UAC feature and should install smoothly.

Should you receive any Windows messages noting a conflict or other UAC
issues, you can disable UAC, install File Transfer Utility, and then re-enable
the UAC feature.

To disable UAC, complete the following steps:
1. Select Start > Control Panel > User Accounts and Family Safety >
User Accounts > Turn User Account Control on or off.

2. Remove the check from the check box located beside “Use User
Account Control (UAC) to help protect your computer” and click OK.

3. Click Restart Now to restart your computer.
To re-enable UAC, repeat the above steps, but recheck the check box

located beside “Use User Account Control (UAC) to help protect your
computer.”
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Setting up the FTP Server During installation of FTU software, an FTP folder structure is created in the
install directory. Folders names in this structure include: archive, drop, error,
upload, ion, and web.

For metered data to be captured and moved into the TMSCE Billing
software, the E4800 and EGX300 devices must write their data files to a
common FTP drop folder. If a drop folder was previously created on your
system to receive data files from the E4800 and EGX300 devices, map a
drive to that folder and point the FTU software to its location during FTU
setup. See the FTU online help file for more information.

Though File Transfer Utility software can access drop folders on other FTP
servers, Microsoft's FTP server is recommended and supported. If you do
not already have an FTP server installed, instructions for configuring
Microsoft's FTP server follow.The FTP server is installed and configured
using Internet Information Service (IIS).

NOTE: If Windows system components are not installed on your system,
you will need to have access to the Windows installation disc to add the FTP
components.

Installing and Configuring FTP using IIS To add the FTP server using 1IS on the Windows XP Pro operating system,
on XP Pro complete the following steps:

1. From Control Panel, click Add or Remove Programs > Add/Remove
Windows Components.

2. Select IIS from the program list, then click Details.

3. Check the File Transfer Protocol Service option, then click Next to
complete the installation.

NOTE: To streamline FTP setup for use with FTU, configure the FTP site
after installing FTU.

To configure the FTP site:

1. From Control Panel, click Administrative Tools, then select Internet
Information Services (IIS6) Manager.

2. Locate the FTP Sites folder and expand the FTP Server node. A default
FTP site is created in the default directory of C:\Inetpub\Ftproot.

3. Right-click on Default FTP Site and select New > Virtual Directory
from the context menu. A virtual directory creation wizard starts. Click
Next.

4. Type drop into the Alias input field. This creates the virtual drop folder
that will receive device data files. Click Next.

5. On the FTP Site Contents screen, the file path you type in or browse to
is the physical location of the virtual drop folder. During FTU installation,
an FTP file structure is created in the FTU install directory. Browse to
and select the drop folder in that directory to establish the connection
between the virtual and physical locations. Click Next to continue.

6. Check both Read and Write privileges for the drop folder. Click Finish
to complete the wizard.

7. Right-click on the newly created drop folder and select Permissions
from the context menu. Set up security permissions for users. (You may
want to consider setting up a specific account that has access privileges
to the FTP site.)

8. Upon completion, verify that the FTP Publishing service is running.
NOTE: After configuring the FTP server, you should run the individual

device's (EGX300 or E4800) configuration tool to verify the device is writing
to the proper location.
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Installing and Configuring FTP using IIS
on Vista

To configure the FTP server using IIS on the Microsoft Vista operating
system, complete the following steps:

1.

From Control Panel, click Programs > Programs and Features >
Turn Windows Features On.
Select IIS.

Check FTP Publishing Service, FTP Management Console and FTP
Server, then click Next to complete the installation.

NOTE: To streamline FTP setup for use with FTU, configure the FTP site
after installing FTU.

To configure the FTP site:

1.

8.

From Control Panel (System and Maintenance), click Administrative
Tools, then select Internet Information Services (IIS) Manager 6.0.

Locate the FTP Sites folder and expand the FTP Server node. A default
FTP site is created during the install in the default directory of
C:\Inetpub\Ftproot.

Right-click on Default FTP Site and select New > Virtual Directory
from the context menu. A virtual directory creation wizard starts. Click
Next.

Type drop into the Alias input field. This creates the virtual drop folder
that will receive device data files. Click Next.

On the FTP Site Contents screen, the file path you type in or browse to
is the physical location of the virtual drop folder. During FTU installation,
an FTP file structure is created in the FTU install directory. Browse to
and select the drop folder in that directory to establish the connection
between the virtual and physical locations. Click Next to continue.
Check both Read and Write privileges for the drop folder. Click Finish
to complete the wizard.

Right-click on the newly created drop folder and select Permissions
from the context menu. Set up security permissions for users. (You may
want to consider setting up a specific account that has access privileges
to the FTP site.)

Upon completion, verify that the FTP Publishing service is running.

NOTE: After configuring the FTP server, you should run the device
(EGX300 or E4800) setup program to verify the device is writing to the
proper location.
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Installing and Configuring FTP using IIS
on Server 2003

To configure the FTP server using IIS on the Microsoft Server 2003
operating system, complete the following steps:

1.

From Control Panel, click Add or Remove Programs > Add/Remove
Windows Components.

Check Application Server and click Details.
Select IS from the program list, then click Details.

Check the File Transfer Protocol Service option, then click Next to
complete the installation.

To configure the FTP site:

1.

8.

From Control Panel, click Administrative Tools, then select Internet
Information Services (IIS6) Manager.

Locate the FTP Sites folder and expand the FTP Server node. A default
FTP site is created in the default directory of C:\Inetpub\Ftproot.

Right-click on Default FTP Site and select New > Virtual Directory
from the context menu. A virtual directory creation wizard starts. Click
Next.

Type drop into the Alias input field. This creates the virtual drop folder
that will receive device data files. Click Next.

On the FTP Site Contents screen, the file path you type in or browse to
is the physical location of the virtual drop folder. During FTU installation,
an FTP file structure is created in the FTU install directory. Browse to
and select the drop folder in that directory to establish the connection
between the virtual and physical locations. Click Next to continue.

Check both Read and Write privileges for the drop folder. Click Finish
to complete the wizard.

Right-click on the newly created drop folder and select Permissions
from the context menu. Set up security permissions for users. (You may
want to consider setting up a specific account that has access privileges
to the FTP site.)

Upon completion, verify that the FTP Publishing service is running.

NOTE: After configuring the FTP server, you should run the device
(EGX300 or E4800) setup program to verify the device is writing to the
proper location.
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Setting up the EGX300 and E4800

Instructions for setting up the EGX300 and the E4800 devices are included
with each device. To ensure optimal performance from File Transfer Utility,
values for logging intervals, logging values, export schedules, and the FTP
server location must be configured. Check the device to verify the following
values have been configured:

Logging interval—This value determines how often data values are
captured. Once every 15 minutes is typical.

Logging values—Essential values to log are Real and Reactive Energy
both delivered and received. Optional values may include Apparent
Energy, Demand (real, reactive, and apparent), and Power Factor.
Optional values will depend on the individual device.

Export schedule—This value tells the device how often to write the data
files to the FTP drop folder and must be configured for the data to be
exported.

FTP server and drop folder—These values are the IP address of the
FTP server and the path to the drop folder that will receive the .csv/.tr3
files.

NTP server—This value is the location of the Network Time Protocol
(NTP) server used as the controller clock for synchronization.

NOTE: The device setup program for both the EGX300 and the E4800
provides the ability to input the IP address for an NTP server. Each
device can use the time source to update its internal clock and keep the
device synchronized with the network. The domain server for the
network typically serves as the time source, but an external source may
also be used. Your system administrator can provide you with the time
source location. If you are unfamiliar with NTP servers, search for
related articles at www.microsoft.com.
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Installing File Transfer Utility

The installation file set for File Transfer Utility software is located in the
PowerLogic File Transfer Utility folder on the TMSCE installation DVD. To
install the software, complete the following steps:

1.

6.

Navigate to the PowerLogic File Transfer Utility folder on the TMSCE
installation DVD and double-click on the setup.exe file found there.

The initial install window displays a message stating preparations are
being made to install and shows a progress bar.

A Welcome screen is displayed. Click Next to continue or Cancel to
end.

An information screen is displayed with a message box containing
information about configuring FTP folders. After reading the message,
click Next to continue or Cancel to end.

If the FTP server is not running, a warning message is displayed. After
reading the message, click OK to continue.

The installation program is now ready to install the software. Click
Install to continue or Cancel to end.

A progress bar showing the installation status followed by a configuring-
system message is displayed during installation.

When the wizard's Complete screen appears, click Finish.

Successful implementation of File Transfer Utility rests mainly in making
sure the E4800 and EGX300 are sending data files to a common FTP folder
and that FTU knows the location of that folder.
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Running the Software During installation, the FTU software is placed in the Windows Program
menu. To run the software, do the following:

1. From the Start menu, select All Programs > PowerLogic File Transfer
Utility > PowerLogic File Transfer Utility.
The PowerLogic File Transfer Utility Client window is displayed.

2. Select File > Setup and proceed to set up the FTU service. Instructions

for setting up the service are found in the on-line help system. Click
Help > Contents from the main menu.

3. To exit the FTU software, select File > Exit.

Troubleshooting For troubleshooting installation problems, contact your local
Square D/Schneider Electric representative for assistance or visit the
technical support web page at www.powerlogic.com.

PowerlLogic™ is a trademark or registered trademark of Schneider Electric. Other

Schneider Electric USA trademarks used herein are the property of their respective owners.

295 Tech Park Dr., Suite 100

Lavergne, TN 37086 USA Electrical equipment should be installed, operated, serviced, and maintained only by
1-888-778-2733 qualified personnel. No responsibility is assumed by Schneider Electric for any
www.powerlogic.com consequences arising out of the use of this material.
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